Well that took longer than it should have, but I managed to upgrade the memory and hard drive in my MSI Wind. The memory was easy – open the case and insert the SIMM – Done. The hard drive was a bit more difficult primarily because I wanted to clone the existing drive with all of the software I had already installed on it and had to do so without the aid of an external CD/DVD drive. I tried a lot of things and this is what ended up working for me. Planning for this upgrade I did buy a Thermaltake BlacX SATA to USB “adapter” which made this process easier since the drives just plug into the top of the BlacX. My target drive is a WD Scorpion 320GB 7200rpm SATA drive that uses slightly less power than the original 5400RPM 160GB Fujitsu. I partitioned the new drive with 3 partitions using my iMac and the OS X disk utility. The partitioning scheme was MBR. First partition was 39.5GB, slightly larger than the Wind’s C: drive. The second is an 80GB HFS+ for OS X – eventually. The third partition is a 200GB FAT32 partition I’ll share with whatever OS is booted. I moved the disk over to my XP notebook and (re)formatted the first partition. I had to do this after trying several other ways to clone the drive. I then downloaded Acronis True Image Home 2009 which has a fully functional 15-day trial. It is nice software and is reasonably priced at $50 – although it did not quite do everything it needed to do as you will see. I put the original Wind HD in the BlacX and made a full backup (including MBR) to an image on my notebook HD. This was a pretty fast process. I then swapped out that drive for the new Scorpion and restored the image to the first partition and replaced the MBR. OK good to go now, right? Wrong. After reassembling the Wind with the new drive I got a little bit further than I had previously using other tools, but came to an abrupt stop with a “Non-System Disk” error during boot. After a little reading I had concluded that the problem was probably the assigned drive letter (D: instead of C:) that True Image gave the clone (you can’t have 2 C: drives on a system). It appeared that there was no way around this. Just for fun, I decided to have a look at the disk using XP’s Disk Manager. So for the umpteenth time I disassembled the Wind and hung the HD on my note book. Naturally I could not change the drive letter to C, but I did notice that the third partition on the drive was marked active. Could it be that simple? I marked the first partition as the active one and reinstalled the disk in the Wind, again. It Booted! … and the drive letter of the boot partition was now C: -  just like I had hoped. So my Wind now has 2GB of RAM and a fast 320GB HD – it is also overclocked to 1.8GHz and is stable. For those who may wonder, it is just as quiet as the original. Oh, and it boots in under 30 seconds.

I hope this is of help to someone out there.